blob: e4446c46c98c2092a856acdc1a8c7148d8dcaf26 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit toolchain-funcs
MY_P=${P/_p/-}
DESCRIPTION="an (often faster than gawk) awk-interpreter"
HOMEPAGE="http://invisible-island.net/mawk/mawk.html"
SRC_URI="ftp://invisible-island.net/mawk/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
RDEPEND="app-eselect/eselect-awk"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
DOCS=( ACKNOWLEDGMENT CHANGES README )
src_prepare() {
tc-export BUILD_CC
}
src_install() {
default
exeinto /usr/share/doc/${PF}/examples
doexe examples/*
docompress -x /usr/share/doc/${PF}/examples
}
pkg_postinst() {
eselect awk update ifunset
}
pkg_postrm() {
eselect awk update ifunset
}