blob: 39defe2b46fc6b0e07f5ee80162759449e40a35c [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils multilib
DESCRIPTION="A nagios plugin for checking logfiles"
HOMEPAGE="http://www.consol.com/opensource/nagios/check-logfiles"
MY_P=${P/nagios-/}
SRC_URI="http://www.consol.com/fileadmin/opensource/Nagios/${MY_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 ~ppc ppc64 ~sparc x86"
IUSE=""
DEPEND=">=net-analyzer/nagios-plugins-1.4.13-r1"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
src_compile() {
econf \
--prefix=/usr \
--libexecdir=/usr/$(get_libdir)/nagios/plugins \
--sysconfdir=/etc/nagios || die "econf failed"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
}