blob: 916a3c68f70ad646947e4739fa0a3e94c3d399ed [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs
DESCRIPTION="An AudioScrobbler client for MPD written in C++"
HOMEPAGE="http://50hz.ws/mpdas/"
SRC_URI="http://50hz.ws/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="media-libs/libmpdclient
net-misc/curl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_compile() {
tc-export CXX
emake CONFIG="/etc"
}
src_install() {
dobin ${PN}
doman ${PN}.1
newinitd "${FILESDIR}/${PN}.init" ${PN}
dodoc mpdasrc.example README
}
pkg_postinst() {
elog "For further configuration help consult the README in"
elog "${EPREFIX}/usr/share/doc/${PF}"
}