blob: 132cab0ef1a04b3f5e1be4afdb74c6337e4382ef [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit cmake-utils user
DESCRIPTION="Another sendmail milter for different mail checks"
SRC_URI="https://github.com/vstakhov/rmilter/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/vstakhov/rmilter"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-libs/libpcre
dev-libs/openssl:0
mail-filter/libmilter
mail-filter/opendkim"
DEPEND="sys-devel/flex
sys-devel/bison
${RDEPEND}"
pkg_setup() {
enewgroup rmilter
enewuser rmilter -1 -1 /var/run/rmilter rmilter
}
src_install() {
cmake-utils_src_install
newinitd "${FILESDIR}/rmilter.initd" rmilter
insinto /etc/rmilter
newins rmilter.conf.sample rmilter.conf.sample
newins rmilter-grey.conf rmilter-grey.conf
}