blob: 17f4a1a1abdec58ae81c9032ef4d4b7f91d15cfb [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
VIRTUALX_REQUIRED="test"
inherit kde5
DESCRIPTION="Framework for intercepting and handling application crashes"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="nls X"
# requires running kde environment
RESTRICT="test"
RDEPEND="
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kwindowsystem)
dev-qt/qtgui:5
X? (
dev-qt/qtx11extras:5
x11-libs/libX11
)
"
DEPEND="${RDEPEND}
nls? ( dev-qt/linguist-tools:5 )
test? ( dev-qt/qtwidgets:5 )
X? ( x11-proto/xproto )
"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package X X11)
)
kde5_src_configure
}