blob: 924bce90710ffe5a9bcc8e184a16240251790755 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
DESCRIPTION="Database of the Italian cookies for the fortune program"
HOMEPAGE="http://www.fortune-it.net/"
SRC_URI="http://www.fortune-it.net/download/fortune-it-${PVR}.tar.gz"
LICENSE="freedist"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="offensive"
DEPEND="games-misc/fortune-mod"
S=${WORKDIR}/fortune-it-${PVR}
src_prepare() {
use offensive || rm -f testi/*-o
}
src_compile() {
local f
for f in testi/* ; do
strfile -s ${f} || die "strfile ${f} failed"
done
}
src_install() {
insinto /usr/share/fortune
doins testi/*
dodoc README
}