blob: 647a732afffce4e1263edba1e64c52f54fe8ab98 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md"
inherit ruby-fakegem
DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
HOMEPAGE="https://github.com/banister/debug_inspector"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}
each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/${PN}.so lib/ || die
}