blob: 604a5d0ac91f44c1488a0799d3d07cde122b6d11 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# jruby → there is code for this in ext but that requires compiling java.
USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_TASK_DOC=""
inherit multilib ruby-fakegem
DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
HOMEPAGE="https://github.com/headius/ruby-atomic"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE=""
all_ruby_prepare() {
# Avoid compilation dependencies since we compile directly.
sed -i -e '/:test => :compile/ s:^:#:' Rakefile || die
}
each_ruby_configure() {
${RUBY} -Cext extconf.rb || die
}
each_ruby_compile() {
emake V=1 -Cext
cp ext/atomic_reference$(get_modname) lib/ || die
}