blob: d8bd786c7f2be6214060ee2701b0ec1f048d510e [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 pypy )
inherit distutils-r1
DESCRIPTION="Module to validate VAT numbers"
HOMEPAGE="https://code.google.com/p/vatnumber/"
SRC_URI="https://vatnumber.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test vies"
RDEPEND="vies? ( dev-python/suds )"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/suds )"
PARCHES=( "${FILESDIR}"/${P}-skiptest.patch )
python_test() {
esetup.py test
}
src_install() {
distutils-r1_src_install
dodoc COPYRIGHT README CHANGELOG
}