blob: c891754b0c30ea3ebf25ecca401bf5d08f3b7b90 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="Backend compiler for high-level typed code"
HOMEPAGE="http://pykit.github.io/pykit/"
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="
dev-python/llvmmath[${PYTHON_USEDEP}]
dev-python/llvmpy[${PYTHON_USEDEP}]
dev-python/networkx[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
"
DEPEND="
test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
cd "${BUILD_DIR}"/lib* || die
${PYTHON} -c "import sys, pykit; sys.exit(pykit.test())" || die
}