blob: b3f0d16879fde56f4bbf457612af0dfb765402a2 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python interface to The Echo Nest APIs"
HOMEPAGE="https://echonest.github.com/pyechonest/"
SRC_URI="https://github.com/echonest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Prevent un-needed download during build
sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/source/conf.py || die
distutils-r1_python_prepare_all
}
python_compile_all() {
use doc && emake -C doc html
}
python_install_all() {
use doc && local HTML_DOCS=( doc/build/html/. )
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}