blob: fd3c22091f764901c83d85f03ecbdda2d549c8d5 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
DESCRIPTION="A small 'shelve' like datastore with concurrency support"
HOMEPAGE="https://github.com/pickleshare/pickleshare"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="
>=dev-python/path-py-6.2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
# test_pickleshare.py is not included in the pickleshare-0.5 source
# we fetched from pipy
RESTRICT="test"
python_test() {
distutils_install_for_testing
cd "${TEST_DIR}"/lib || die
cp "${S}"/test_pickleshare.py "${TEST_DIR}"/lib/ || die
py.test || die
}