blob: bdbfe682937c2c88477f77442ad4b79ba06440f3 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )
inherit distutils-r1
DESCRIPTION="A WSGI object-dispatching web framework, designed to be lean and fast, with few dependencies."
HOMEPAGE="https://pypi.python.org/pypi/pecan"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
dev-python/simplejson[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
>=dev-python/webob-1.4[${PYTHON_USEDEP}]
>=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
>=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"