blob: 44b1a93332f71d09c42f51074bde1af93af8097d [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python API and tools to manipulate OpenDocument files"
HOMEPAGE="https://joinup.ec.europa.eu/software/odfpy/home https://pypi.python.org/pypi/odfpy"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
PATCHES=( "${FILESDIR}/${PN}-0.9.4-tests.patch" )
python_test() {
local exit_status=0 test
for test in tests/test*.py; do
einfo "Running ${test} ..."
"${PYTHON}" "${test}"
[[ $? -ne 0 ]] && exit_status=1
done
return ${exit_status}
}