blob: 0c28107dc52fe728bed494a4e27d2bcfc15d27a3 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python library to manipulate Google APIs"
HOMEPAGE="https://github.com/google/apitools"
SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
RDEPEND=">=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
>=dev-python/oauth2client-1.4.8[${PYTHON_USEDEP}]
>=dev-python/protorpc-0.9.1[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/google-apputils-0.4.0[${PYTHON_USEDEP}]
>=dev-python/python-gflags-2.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
S="${WORKDIR}/apitools-${PV}"