blob: 39b79f26640b2b407009277cd031841354d0a2a1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
MY_PN="CouchDB"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Python library for working with CouchDB"
HOMEPAGE="https://code.google.com/p/couchdb-python/ https://pypi.python.org/pypi/CouchDB"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]"
S=${WORKDIR}/${MY_P}
# Tests require connectivity to a couchdb server.
# Re-enable when the ebuild is capable of starting a local couchdb
# instance.
RESTRICT=test
PATCHES=( "${FILESDIR}/${PV}-exec-compat.patch" )
python_compile_all() {
esetup.py build_sphinx
}
python_test() {
esetup.py test
}
python_install_all() {
use doc && local HTML_DOCS=( doc/build/html/. )
distutils-r1_python_install_all
}