blob: a0d2d80851fb2f4a9f6329b83b7a8bb7d59eeb89 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="Read/rewrite/write Python ASTs"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
HOMEPAGE="https://pypi.python.org/pypi/astor"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_prepare_all() {
#avoid file collisions picked up by the eclass
sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
distutils-r1_python_prepare_all
}
python_test() {
"${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
}