blob: ff0a798ec738e647d98323a0b6daf865b28e4909 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
DESCRIPTION="Libkpass is a from-scratch C implementation of accessing KeePass 1.x format password databases"
HOMEPAGE="http://libkpass.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="static-libs"
RDEPEND=">=dev-libs/nettle-2.7.1"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog README TODO )
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm -f "${ED}"/usr/lib*/${PN}.la
}