blob: 0811f962c82a72044cfc762a8c3ca16a3685693c [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit flag-o-matic multilib
DESCRIPTION="OpenDBX - A database abstraction layer"
HOMEPAGE="http://www.linuxnetworks.de/doc/index.php/OpenDBX"
SRC_URI="http://www.linuxnetworks.de/opendbx/download/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="firebird +mysql oracle postgres sqlite"
RESTRICT="firebird? ( bindist )"
DEPEND="mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:* )
sqlite? ( dev-db/sqlite:3 )
oracle? ( dev-db/oracle-instantclient-basic )
firebird? ( dev-db/firebird )"
RDEPEND="${DEPEND}"
pkg_setup() {
if ! ( use firebird || use mysql || use oracle || use postgres || use sqlite )
then
ewarn "You should enable at least one of the following USE flags:"
ewarn "firebird, mysql, oracle, postgres or sqlite"
fi
if use oracle && [[ ! -d ${ORACLE_HOME} ]]
then
die "Oracle support requested, but ORACLE_HOME not set to a valid directory!"
fi
use mysql && append-cppflags -I/usr/include/mysql
use firebird && append-cppflags -I/opt/firebird/include
use oracle && append-ldflags -L"${ORACLE_HOME}"/lib
}
src_configure() {
local backends=""
use firebird && backends="${backends} firebird"
use mysql && backends="${backends} mysql"
use oracle && backends="${backends} oracle"
use postgres && backends="${backends} pgsql"
use sqlite && backends="${backends} sqlite3"
econf --with-backends="${backends}"
}
src_compile() {
# bug #322221
emake -j1
}
src_install() {
emake -j1 install DESTDIR="${D}"
dodoc AUTHORS ChangeLog README
rm -f "${D}"/usr/$(get_libdir)/opendbx/*.{a,la}
}