blob: 88cf0004ce7a3dbc83e967f3dcd6a0f6d1e5d56a [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit unpacker toolchain-funcs
DESCRIPTION="GNU Ocrad is an OCR (Optical Character Recognition) program"
HOMEPAGE="https://www.gnu.org/software/ocrad/ocrad.html"
SRC_URI="mirror://nongnu/${PN}/${P}.tar.lz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
RDEPEND=""
DEPEND="$(unpacker_src_uri_depends)"
DOCS="AUTHORS ChangeLog NEWS README"
src_configure() {
# ./configure is not based on autotools
./configure \
CPPFLAGS="${CPPFLAGS}" \
CXX="$(tc-getCXX)" \
CXXFLAGS="${CXXFLAGS}" \
LDFLAGS="${LDFLAGS}" \
--prefix=/usr
}
src_install() {
default
doman doc/${PN}.1
doinfo doc/${PN}.info
}