blob: e5d0edd16ffb297a04e6b3e2413386ea333fa2ff [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
DESCRIPTION="Check live packages for updates and emerge them as necessary"
HOMEPAGE="https://bitbucket.org/mgorny/smart-live-rebuild/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 arm ~mips x86 ~x86-fbsd"
IUSE=""
RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
python_test() {
esetup.py test
}
python_install_all() {
distutils-r1_python_install_all
insinto /etc/portage
newins smart-live-rebuild.conf{.example,}
insinto /usr/share/portage/config/sets
newins sets.conf.example ${PN}.conf
}