blob: 4c7602d3f9cb7a99fb71c33bbb36dc9a23f487e8 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
inherit leechcraft
DESCRIPTION="Full-featured BitTorrent client plugin for LeechCraft"
SLOT="0"
KEYWORDS=""
IUSE="debug geoip"
DEPEND="~app-leechcraft/lc-core-${PV}
net-libs/rb_libtorrent"
RDEPEND="${DEPEND}
virtual/leechcraft-task-show
geoip? ( dev-libs/geoip )"
src_configure(){
local mycmakeargs="
$(cmake-utils_use_enable geoip BITTORRENT_GEOIP)
"
cmake-utils_src_configure
}