blob: 82633d12847be347f658c43a9eb2d91487ce9b7a [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils
MY_P=${PN}-${PV/./-}
DESCRIPTION="The GNU Emacs Lisp Reference Manual"
HOMEPAGE="https://www.gnu.org/software/emacs/manual/"
SRC_URI="mirror://gnu/emacs/${MY_P}.tar.gz
https://dev.gentoo.org/~ulm/emacs/${P}-patches.tar.gz"
LICENSE="FDL-1.1+"
SLOT="21"
KEYWORDS="amd64 ppc x86"
DEPEND="sys-apps/texinfo"
S="${WORKDIR}/${MY_P}"
src_prepare() {
# remove pre-made info files
rm -f elisp elisp-[0-9]*
EPATCH_SUFFIX=patch epatch
}
src_compile() {
ln -s index.unperm index.texi || die
makeinfo elisp.texi || die
}
src_install() {
doinfo elisp21.info*
dodoc README
}