blob: b3249988f1c90c7dd92a68b9f8274dba54822990 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python3_4 )
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/jborg/attic.git"
inherit git-r3
else
SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
DESCRIPTION="Attic is a deduplicating backup program written in Python."
HOMEPAGE="https://attic-backup.org/"
LICENSE="BSD"
SLOT="0"
IUSE="libressl"
RDEPEND="
dev-python/msgpack[${PYTHON_USEDEP}]
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
dev-python/llfuse[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${RDEPEND}"