blob: 97d2ea0267a38d63130cf61b37681779648bbe35 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit toolchain-funcs
DESCRIPTION="Another uncompressor for compatibility"
HOMEPAGE="https://github.com/vapier/ncompress"
SRC_URI="mirror://sourceforge/ncompress/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE=""
src_compile() {
tc-export CC
emake
}
src_install() {
dobin compress
dosym compress /usr/bin/uncompress
doman compress.1
echo '.so compress.1' > "${ED}"/usr/share/man/man1/uncompress.1
dodoc Acknowleds Changes LZW.INFO README
}