blob: 5999d202f7f443cd1d6a3f0d0236e3d66efe1c8d [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit eutils fdo-mime multilib toolchain-funcs
DESCRIPTION="PC/SC Architecture smartcard tools"
HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE="gtk network-cron"
RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
DEPEND="${RDEPEND}
virtual/pkgconfig"
RDEPEND="${RDEPEND}
dev-perl/pcsc-perl
gtk? ( dev-perl/gtk2-perl )"
src_prepare() {
sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
}
src_compile() {
# explicitly only build the pcsc_scan application, or the man
# pages will be gzipped first, and then unpacked.
emake pcsc_scan CC=$(tc-getCC)
}
src_install() {
# install manually, makes it much easier since the Makefile
# requires fiddling with
dobin ATR_analysis scriptor pcsc_scan
doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
dodoc README Changelog
if use gtk; then
domenu gscriptor.desktop
dobin gscriptor
doman gscriptor.1p
fi
if use network-cron ; then
exeinto /etc/cron.monthly
newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
fi
insinto /usr/share/pcsc
doins smartcard_list.txt
}
pkg_postinst() {
use gtk && fdo-mime_desktop_database_update
}
pkg_postrm() {
fdo-mime_desktop_database_update
}