blob: 979b375ee78521824d45cd48a201cf525058b62b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
DESCRIPTION="A library for interfacing Music Player Daemon (media-sound/mpd)"
HOMEPAGE="http://www.musicpd.org"
SRC_URI="http://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
IUSE="doc examples static-libs"
RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
sed -e "s:@top_srcdir@:.:" -i doc/doxygen.conf.in
}
src_configure() {
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
$(use_enable static-libs static) \
$(use_enable doc documentation)
}
src_install() {
default
use examples && dodoc src/example.c
use doc || rm -rf "${ED}"/usr/share/doc/${PF}/html
find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
}