blob: 71c838660d4b97c6e16262433016469e000699fc [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
WX_GTK_VER="3.0"
inherit eutils wxwidgets
DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-wxgtk.patch
}
src_configure() {
econf --with-wx-config=${WX_CONFIG}
}
src_install() {
dobin source/wxchtdecoder
dodoc docs/wxchtdecoder.txt
}