blob: faafdd1e8e96b1de9a0247f870becaacdbb64d15 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"
RUBY_FAKEGEM_EXTRADOC="changelog.txt Readme.md"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
DESCRIPTION="This library reads and writes .netrc files"
HOMEPAGE="https://github.com/geemus/netrc"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE=""
all_ruby_prepare() {
sed -e '/test_encrypted_roundtrip/,/^ end/ s:^:#:' -i test/test_netrc.rb || die
}
each_ruby_test() {
${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
}