blob: d83bc28e8bfe6df68c169d71d1a7b811d26d174b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit qt5-build virtualx
DESCRIPTION="Set of QML types for adding visual effects to user interfaces"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
fi
IUSE=""
RDEPEND="
>=dev-qt/qtcore-${PV}:5
>=dev-qt/qtdeclarative-${PV}:5
"
DEPEND="${RDEPEND}
test? ( >=dev-qt/qtgui-${PV}:5 )
"
src_test() {
local VIRTUALX_COMMAND="qt5-build_src_test"
virtualmake
}