blob: 76fcf03433637867b52dadb7cbb0b907857ecff4 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
MY_PN=${PN/-/.}
MY_P=${MY_PN}-${PV}
inherit distutils-r1
DESCRIPTION="Tools and templates to customize Sphinx for STScI projects"
HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpydoc[$(python_gen_usedep python2_7)]"
DEPEND="${RDEPEND}
>=dev-python/d2to1-0.2.9[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/stsci-distutils-0.3.2[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"