blob: 5bf056fffca3c4dc5c0ef7b40c7040f6e38ee366 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
DESCRIPTION="Simple generic functions for Python"
HOMEPAGE="https://pypi.python.org/pypi/simplegeneric"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
DEPEND="
app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
python_test() {
esetup.py test
}