blob: 135c96317432f3d3453e7e4e32b695899203f560 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Python modules to access System V shared memory and semaphores"
HOMEPAGE="http://nikitathespider.com/python/shm/"
SRC_URI="http://nikitathespider.com/python/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="examples"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
PATCHES=( "${FILESDIR}"/${P}-compiler.patch )
python_install_all() {
dohtml ReadMe.html
use examples && local EXAMPLES=( demo/. )
distutils-r1_python_install_all
}