blob: e50de463a3dfef14ee76ae0cc3238dbce49a0d21 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=(python{2_7,3_3})
inherit distutils-r1
DESCRIPTION="Python subprocess interface"
HOMEPAGE="https://github.com/amoffat/sh"
SRC_URI="https://github.com/amoffat/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
${PYTHON} test.py || die
}