blob: 17cfdabe4b834e2e0312f5142aad73353d9ce37b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1 eutils
DESCRIPTION="QR Code generator on top of PIL"
HOMEPAGE="https://pypi.python.org/pypi/qrcode"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
python_test() {
"${PYTHON}" -m unittest qrcode.tests || die "Testing failed with ${EPYTHON}"
}
pkg_postist() {
optfeature "svg backend" dev-python/lxml
optfeature "PIL backend" dev-python/pillow
}