blob: cdda7da27b5ee1dfaf68adef3be60880973de6b4 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Client library for Barbican API."
HOMEPAGE="https://github.com/openstack/barbican"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
"
RDEPEND="
>=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
!~dev-python/requests-2.4.0[${PYTHON_USEDEP}]
>=dev-python/six-1.7.0[${PYTHON_USEDEP}]
>=dev-python/python-keystoneclient-0.11.2[${PYTHON_USEDEP}]
>=dev-python/cliff-1.7.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-1.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.0.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-1.0.0[${PYTHON_USEDEP}]
"