blob: 57118f481a27211f7f21dc9d03d20fe968a78843 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1 flag-o-matic
MY_P="pyPgSQL-${PV}"
DESCRIPTION="Python Interface to PostgreSQL"
HOMEPAGE="http://pypgsql.sourceforge.net/ https://pypi.python.org/pypi/pyPgSQL"
SRC_URI="mirror://sourceforge/pypgsql/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ia64 x86"
IUSE="examples"
DEPEND="dev-db/postgresql:*"
RDEPEND="${DEPEND}
dev-python/egenix-mx-base[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
append-cflags -fno-strict-aliasing
distutils-r1_python_prepare_all
}
python_install_all() {
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}