blob: 444c5ee1e55062c06578e6511022ebb01e92081c [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Cross-platform windowing and multimedia library for Python"
HOMEPAGE="http://www.pyglet.org/"
SRC_URI="https://pyglet.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="alsa doc examples gtk +openal"
RDEPEND="
virtual/opengl
alsa? ( media-libs/alsa-lib[alisp] )
gtk? ( x11-libs/gtk+:2 )
openal? ( media-libs/openal )"
DEPEND="${RDEPEND}"
# ffmpeg? ( media-libs/avbin-bin )
DOCS="NOTICE"
python_install_all() {
use doc && HTML_DOCS=( doc/html/. )
use examples && EXAMPLES=( examples )
distutils-r1_python_install_all
}