blob: 876afce796f7ce79fb2fb08fa8341af3d0f2d0ab [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="Python bindings for libasyncns"
HOMEPAGE="https://launchpad.net/libasyncns-python/"
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=">=net-libs/libasyncns-0.4"
RDEPEND="${DEPEND}"
python_compile() {
if [[ ${EPYTHON} != python3* ]]; then
local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
fi
distutils-r1_python_compile
}
# Tests are network-dependent