blob: c86327c6564ba3dc8d82d20e8672f7245ec3c496 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
inherit distutils-r1
DESCRIPTION="JavaScript minifier"
HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
IUSE=""
LICENSE="MIT"
SLOT="0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
"${PYTHON}" -m ${PN}.test || die
}