blob: c77321ac2de92a7f4eb9b5c29528d13bc4e8f1b1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
DESCRIPTION="JavaScript minifier"
HOMEPAGE="https://bitbucket.org/dcs/jsmin/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="amd64 x86"
IUSE=""
LICENSE="MIT"
SLOT="0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
pushd "${BUILD_DIR}"/lib > /dev/null
"${PYTHON}" -m ${PN}.test || die
popd > /dev/null
}