blob: 997522e5655c51a91abc4aa4f95547a93443e926 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
PYTHON_DEPEND="2"
PYTHON_USE_WITH="ssl(+) xml"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
MY_P="gdata-${PV}"
DESCRIPTION="Python client library for Google data APIs"
HOMEPAGE="https://code.google.com/p/gdata-python-client/ https://pypi.python.org/pypi/gdata"
SRC_URI="https://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="examples"
DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="atom gdata"
src_test() {
testing() {
PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_data_tests.py -v || return 1
# run_service_tests.py requires interaction (and a valid Google account), so skip it.
# PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_service_tests.py -v || return 1
}
python_execute_function testing
}
src_install() {
distutils_src_install
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins -r samples/* || die "Installation of examples failed"
fi
}