blob: 932ca799e9987c771264d539435b18309a7b3cdb [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
MY_PN="Cycler"
DESCRIPTION="Composable style cycles"
HOMEPAGE="
http://tacaswell.github.io/cycler/
https://pypi.python.org/pypi/Cycler/
http://github.com/matplotlib/cycler"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE=""
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"
# Not shipped
# https://github.com/matplotlib/cycler/issues/21
RESTRICT=test
python_test() {
${PYTHON} run_tests.py || die
}