blob: f1fbc7a9de9410a6fd952d0a19435468e16ae755 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit xfconf
DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug libnotify"
RDEPEND=">=dev-libs/glib-2.28
>=x11-libs/gtk+-2.20:2
x11-libs/libX11
>=xfce-base/exo-0.6
>=xfce-base/libxfce4ui-4.8
>=xfce-base/libxfce4util-4.8
>=xfce-base/xfce4-panel-4.8
>=xfce-base/xfconf-4.8
libnotify? ( >=x11-libs/libnotify-0.7 )"
DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig"
pkg_setup() {
XFCONF=(
$(use_enable libnotify notifications)
$(xfconf_use_debug)
)
DOCS=( AUTHORS ChangeLog NEWS README TODO )
}