blob: 137312bed2a8b482d1138b50dc6fc94f3cb3d5b1 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
HORDE_PHP_FEATURES="session xml"
inherit horde
DESCRIPTION="Horde Application Framework"
HOMEPAGE="http://www.horde.org/"
KEYWORDS="alpha amd64 hppa ~ia64 ppc sparc x86"
IUSE="mysql"
DEPEND=""
RDEPEND="dev-lang/php
>=sys-devel/gettext-0.10.40
>=dev-libs/libxml2-2.4.21
>=www-apps/horde-pear-1.3
dev-php/PEAR-Log
dev-php/PEAR-Mail_Mime
mysql? ( dev-php/PEAR-DB )"
src_unpack() {
horde_src_unpack
cd "${S}"
chmod 600 scripts/sql/create.*.sql #137510
}
pkg_postinst() {
horde_pkg_postinst
elog "Horde requires PHP to have:"
elog " ==> 'short_open_tag enabled = On'"
elog " ==> 'magic_quotes_runtime set = Off'"
elog " ==> 'file_uploads enabled = On'"
}