blob: 2186746a1eec44b68bbe63f201ec32984b0c6217 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
MY_P="${P/icecream/icecc}"
inherit base eutils user
DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
HOMEPAGE="https://github.com/icecc/icecream"
SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="
sys-libs/libcap-ng
"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${P}-libcap-ng.patch"
)
pkg_setup() {
enewgroup icecream
enewuser icecream -1 -1 /var/cache/icecream icecream
}
src_configure() {
econf \
--enable-shared --disable-static \
--enable-clang-wrappers \
--enable-clang-rewrite-includes
}
src_install() {
default
prune_libtool_files --all
newconfd suse/sysconfig.icecream icecream
newinitd "${FILESDIR}"/icecream-r2 icecream
insinto /etc/logrotate.d
newins suse/logrotate icecream
}