blob: c67131f0beaebdd3632fa19e906fb3478e881a1e [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
inherit toolchain-funcs unpacker
DESCRIPTION="Your basic line editor"
HOMEPAGE="https://www.gnu.org/software/ed/"
SRC_URI="mirror://gnu/ed/${P}.tar.lz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
DEPEND="$(unpacker_src_uri_depends)
sys-apps/texinfo"
RDEPEND=""
src_configure() {
# Upstream configure script is moronic.
econf \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}" \
LDFLAGS="${CFLAGS} ${LDFLAGS}" \
CPPFLAGS="${CPPFLAGS}" \
--bindir="${EPREFIX}/bin"
}