blob: f1f855c434a8db6c625e43825f6bfeb828d09daf [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
AUTOTOOLS_AUTORECONF=yes
inherit eutils autotools-utils
DESCRIPTION="Scientific calculator designed to provide maximum usability"
HOMEPAGE="http://calcoo.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
PATCHES=( "${FILESDIR}"/${P}-gold.patch )
src_configure() {
local myeconfargs=( --disable-gtktest )
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
newicon src/pixmaps/main.xpm ${PN}.xpm
make_desktop_entry ${PN} Calcoo ${PN} "Education;Math"
}