blob: 77a0fe85b1a8007501f573db247efc7c5023f4b1 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=2
DESCRIPTION="C++ library to scrobble tracks on Last.fm"
HOMEPAGE="https://code.google.com/p/lastfmlib/"
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug syslog"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
src_configure() {
econf \
--disable-dependency-tracking \
--disable-static \
$(use_enable debug) \
$(use_enable syslog logging) \
--disable-unittests
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog
find "${D}"/usr -name '*.la' -delete
}