blob: 4a8b2a3ef90d5e3fca75c631d644228bdf1dc67d [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
AUTOTOOLS_AUTORECONF=1
inherit autotools-utils flag-o-matic vcs-snapshot
DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
HOMEPAGE="https://github.com/FFMS/ffms2"
SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/4"
KEYWORDS="~amd64 ~x86"
IUSE="libav static-libs"
RDEPEND="
sys-libs/zlib
!libav? ( >=media-video/ffmpeg-2.4:0= )
libav? ( >=media-video/libav-9:0= )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
PATCHES=(
"${FILESDIR}/${P}-fix-pixfmt-define.patch"
"${FILESDIR}/${P}-include-missing-header.patch"
"${FILESDIR}/${P}-add-missing-extern-C.patch"
)
pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11; then
die "Your compiler lacks C++11 support. Use GCC>=4.7.0 or Clang>=3.3."
fi
}